Rocket.Chat开发环境搭建

头像
码农笔录
2020-09-27阅读 113

官方文档不支持在windows上搭建rocket chat的开发环境,我自己也尝试过,最后放弃了,选择了linux环境。
image.png
我尝试过Deepin,按照官方文档一把过,用Ubuntu20(最低要求18+)的时候遇到一些小问题,就是有个python的库找不到,换了个版本就好了。如果你之前没有安装node和MongoDB,也不需要专门去安装,因为meteor给你自带了。
按照以下顺序执行命令基本没问题,如果很慢,请自行翻墙

1.安装基本库

sudo apt install g++ build-essential git curl python-minimal -y

如果提示你python-minimal找不到,那你就安装python2-minimal

image.png

2.安装meteor

curl https://install.meteor.com/ | sh

如果很慢或者失败,请自行翻墙
安装完成之后可以通过以下命令查看meteor自带的node和npm版本

meteor node -v
meteor npm -v

3.克隆代码

git clone https://github.com/RocketChat/Rocket.Chat.git

4.安装依赖

cd Rocket.Chat
meteor npm install

如果安装依赖很慢,或者有包找不到失败了,可以将npm的镜像源设置成阿里的

meteor npm config set registry https://registry.npm.taobao.org --global

5.运行程序

meteor npm start

这个步骤很慢,不要以为卡死了,中间也会报很多错误,没到最后一步自动停止请不要手动停止。

我在deepin20上安装运行一把过,Ubuntu20上就遇到一个问题,python的那个包找不到,最后如果你能看到下面这个界面,表示你已经吧开发环境搭建好了。meteor程序默认端口3000,MongoDB默认端口是3001
image.png