meteor no plugin found for accounts_ui.styl in ian:accounts-ui-bootstrap-3

头像
码农笔录
2020-09-28阅读 99

Errors prevented startup:

While building for web.browser:
error: no plugin found for accounts_ui.styl in ian:accounts-ui-bootstrap-3; a plugin for *.styl was active when it was published but none is now

While building for web.browser.legacy:
error: no plugin found for accounts_ui.styl in ian:accounts-ui-bootstrap-3; a plugin for *.styl was active when it was published but none is now

Your application has errors. Waiting for file change.

应该是安装包的时候前后顺序不对导致的stylus的版本冲突,默认依赖下载的版本较低

解决方案:

1.删除依赖
meteor remove ian:accounts-ui-bootstrap-3

2.先添加stylus的依赖
meteor add stylus

3.然后安装ian:accounts-ui-bootstrap-3(默认依赖的版本是1.x,单独安装的版本是2.x)
meteor add ian:accounts-ui-bootstrap-3